aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb')
-rw-r--r--meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb b/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb
index 122dfc0001..528289b7fd 100644
--- a/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb
+++ b/meta-networking/recipes-support/http-parser/http-parser_2.9.4.bb
@@ -6,7 +6,6 @@ DESCRIPTION = "This is a parser for HTTP messages written in C. It parses \
interrupted at anytime. Depending on your architecture, it \
only requires about 40 bytes of data per message stream (in a \
web server that is per connection)."
-AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>"
HOMEPAGE = "https://github.com/nodejs/http-parser"
SECTION = "libs"
LICENSE = "MIT"
@@ -17,6 +16,8 @@ SRCREV = "2343fd6b5214b2ded2cdcf76de2bf60903bb90cd"
S = "${WORKDIR}/git"
+EXTRA_OEMAKE = "PLATFORM=linux"
+
do_configure[noexec] = "1"
do_compile() {
@@ -24,7 +25,7 @@ do_compile() {
}
do_install() {
- oe_runmake install DESTDIR=${D} PREFIX=${prefix}
+ oe_runmake install DESTDIR=${D} PREFIX=${prefix} LIBDIR=${libdir}
}
BBCLASSEXTEND = "native nativesdk"