aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-extended/dlm/dlm_4.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-extended/dlm/dlm_4.2.0.bb')
-rw-r--r--meta-networking/recipes-extended/dlm/dlm_4.2.0.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-networking/recipes-extended/dlm/dlm_4.2.0.bb b/meta-networking/recipes-extended/dlm/dlm_4.2.0.bb
index 5073192763..bd71f70e3c 100644
--- a/meta-networking/recipes-extended/dlm/dlm_4.2.0.bb
+++ b/meta-networking/recipes-extended/dlm/dlm_4.2.0.bb
@@ -10,6 +10,7 @@ SRC_URI = "https://pagure.io/dlm/archive/dlm-${PV}/dlm-dlm-${PV}.tar.gz \
file://0001-make-Replace-cp-a-with-mode-preserving-options.patch \
file://0001-dlm_controld-remove-unnecessary-header-include.patch \
file://0001-Disable-annobin-plugin.patch \
+ file://0001-Remove-fcf-protection-full.patch \
"
SRC_URI[sha256sum] = "90237e18af7422ac15fc756899b3bb6932597b13342296de8e0e120e6d8729ab"
@@ -35,14 +36,15 @@ SYSTEMD_AUTO_ENABLE = "enable"
export EXTRA_OEMAKE = ""
+CFPROTECTION ?= "-fcf-protection=full"
+CFPROTECTION:riscv64 = ""
+
+CFLAGS += "${CFPROTECTION}"
+
PARALLEL_MAKE = ""
DONTBUILD = "${@bb.utils.contains('PACKAGECONFIG', 'pacemaker', '', 'fence', d)}"
-do_compile:prepend:toolchain-clang() {
- sed -i -e "s/-fstack-clash-protection//g" ${S}/*/Makefile
-}
-
do_compile() {
sed -i "s/libsystemd-daemon/libsystemd/g" ${S}/dlm_controld/Makefile
sed -i -e "s/ ${DONTBUILD}//g" ${S}/Makefile
@@ -59,4 +61,3 @@ do_install() {
install -Dm 0644 ${S}/init/dlm.service ${D}${systemd_unitdir}/system/dlm.service
fi
}
-