aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.1.bb')
-rw-r--r--meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.1.bb b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.1.bb
index f7d040d73c..bc04a3037a 100644
--- a/meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.1.bb
+++ b/meta-gnome/recipes-gnome/gtksourceview/gtksourceview4_4.8.1.bb
@@ -22,4 +22,16 @@ SRC_URI[sha256sum] = "d163d71b5fcafbc5b1eec6dd841edbdbcddd3a7511cd5fdcffd86b8bbf
GIR_MESON_OPTION = 'gir'
GTKDOC_MESON_OPTION = "gtk_doc"
+# Override the definition in meson.bbclass. The dependencies in mason.build are incomplete
+# and the recipe will not build with "-j 1". This fix is benign but should be reviewed when
+# updating versions.
+#
+meson_do_compile() {
+ bbnote "========== generating gtksourceview-gresources.h ========"
+ bbnote "PARALLEL_MAKE is ${PARALLEL_MAKE}"
+ ninja ${PARALLEL_MAKE} gtksourceview/gtksourceview-gresources.h
+ bbnote "========== compiling target all ========"
+ ninja ${PARALLEL_MAKE}
+}
+
FILES_${PN} += "${datadir}/gtksourceview-4"