aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb')
-rw-r--r--meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb
new file mode 100644
index 0000000000..5a926dac0c
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/sshfs-fuse/sshfs-fuse_3.7.3.bb
@@ -0,0 +1,30 @@
+SUMMARY = "This is a filesystem client based on the SSH File Transfer Protocol using FUSE"
+HOMEPAGE = "https://github.com/libfuse/sshfs"
+SECTION = "console/network"
+LICENSE = "GPL-2.0-only"
+DEPENDS = "glib-2.0 fuse3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRC_URI = "git://github.com/libfuse/sshfs;branch=master;protocol=https \
+ file://03ee1f8aa0899268ec02b2f54849352df92a3a1d.patch \
+ file://a1d58ae1be99571a88b8439b027abe6349b74658.patch \
+"
+SRCREV = "c91eb9a9a992f1a36c49a8e6f1146e45b5e1c8e7"
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+ bash \
+ fuse \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test
+ cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
+}