aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python3-kiwisolver_1.1.0.bb16
-rw-r--r--meta-python/recipes-devtools/python/python3-kiwisolver_1.2.0.bb20
2 files changed, 20 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python3-kiwisolver_1.1.0.bb b/meta-python/recipes-devtools/python/python3-kiwisolver_1.1.0.bb
deleted file mode 100644
index a108302578..0000000000
--- a/meta-python/recipes-devtools/python/python3-kiwisolver_1.1.0.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-SUMMARY = "A fast implementation of the Cassowary constraint solver"
-HOMEPAGE = "https://github.com/nucleic/kiwi"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://setup.py;endline=7;md5=1c177d169db050341d3b890c69fb80e3"
-
-SRC_URI[md5sum] = "fc8a614367f7ba0d34a02fd08c535afc"
-SRC_URI[sha256sum] = "53eaed412477c836e1b9522c19858a8557d6e595077830146182225613b11a75"
-
-inherit pypi setuptools3
-
-RDEPENDS_${PN} += "\
- python3-core \
- python3-setuptools \
-"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-kiwisolver_1.2.0.bb b/meta-python/recipes-devtools/python/python3-kiwisolver_1.2.0.bb
new file mode 100644
index 0000000000..94db61142b
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-kiwisolver_1.2.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A fast implementation of the Cassowary constraint solver"
+HOMEPAGE = "https://github.com/nucleic/kiwi"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://setup.py;endline=7;md5=e54bd74bd9d0a84ae3f8f6d21ada0ab4"
+
+SRC_URI[md5sum] = "9f53fabb361c04d76c5afc688652c814"
+SRC_URI[sha256sum] = "247800260cd38160c362d211dcaf4ed0f7816afb5efe56544748b21d6ad6d17f"
+
+inherit pypi setuptools3
+
+DEPENDS += "\
+ python3-cppy-native \
+"
+
+RDEPENDS_${PN} += "\
+ python3-core \
+ python3-setuptools \
+"
+
+BBCLASSEXTEND = "native nativesdk"