aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorricoheller <rico.heller@gmail.com>2023-05-18 11:50:24 -0300
committerKhem Raj <raj.khem@gmail.com>2023-05-18 10:26:13 -0700
commitce56fd4336b9162b11807fa063c745b7984af113 (patch)
treef14f8193a34d97c656cecebe0bf0301d6c1898c2 /meta-python
parent6b23d6fcef9f480ebbcada1ffa98d16125a570ba (diff)
downloadmeta-openembedded-ce56fd4336b9162b11807fa063c745b7984af113.tar.gz
python3-dbus-fast: add recipe
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-dbus-fast_1.85.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dbus-fast_1.85.0.bb b/meta-python/recipes-devtools/python/python3-dbus-fast_1.85.0.bb
new file mode 100644
index 0000000000..6e1b599351
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dbus-fast_1.85.0.bb
@@ -0,0 +1,15 @@
+SUMMARY = "A faster version of dbus-next originally from the great DBus next library."
+HOMEPAGE = "https://github.com/bluetooth-devices/dbus-fast"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=729e372b5ea0168438e4fd4a00a04947"
+
+SRC_URI[sha256sum] = "af346e87e34fa52c7ae82d117303cbfe089cd5391b5a1cc0e51f67066ef426f5"
+
+PYPI_PACKAGE = "dbus_fast"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-core (>=3.7) \
+ python3-async-timeout \
+"