aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-12 12:47:54 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-13 21:34:21 -0700
commitb6b29b8210c6e024403a3bec0c995b9921dc8004 (patch)
treea4df2b0e65020c358be79f410993dff1cafeb465 /meta-python
parent5e1b86c1b23a404fa2c9358e03e1b593e308730d (diff)
downloadmeta-openembedded-b6b29b8210c6e024403a3bec0c995b9921dc8004.tar.gz
python3-packaging: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-packaging.inc10
-rw-r--r--meta-python/recipes-devtools/python/python3-packaging_20.3.bb12
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-packaging.inc b/meta-python/recipes-devtools/python/python-packaging.inc
deleted file mode 100644
index 418483f4e8..0000000000
--- a/meta-python/recipes-devtools/python/python-packaging.inc
+++ /dev/null
@@ -1,10 +0,0 @@
-DESCRIPTION = "Core utilities for Python packages"
-HOMEPAGE = "https://github.com/pypa/packaging"
-LICENSE = "Apache-2.0 & BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
-
-SRC_URI[md5sum] = "19e0d1f82a9007b448650ccfeffd0a26"
-SRC_URI[sha256sum] = "3c292b474fda1671ec57d46d739d072bfd495a4f51ad01a055121d81e952b7a3"
-
-DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
-RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing"
diff --git a/meta-python/recipes-devtools/python/python3-packaging_20.3.bb b/meta-python/recipes-devtools/python/python3-packaging_20.3.bb
index aa20fb26f9..9eee84b1b2 100644
--- a/meta-python/recipes-devtools/python/python3-packaging_20.3.bb
+++ b/meta-python/recipes-devtools/python/python3-packaging_20.3.bb
@@ -1,2 +1,12 @@
+DESCRIPTION = "Core utilities for Python packages"
+HOMEPAGE = "https://github.com/pypa/packaging"
+LICENSE = "Apache-2.0 & BSD"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=faadaedca9251a90b205c9167578ce91"
+
+SRC_URI[md5sum] = "19e0d1f82a9007b448650ccfeffd0a26"
+SRC_URI[sha256sum] = "3c292b474fda1671ec57d46d739d072bfd495a4f51ad01a055121d81e952b7a3"
+
inherit pypi setuptools3
-require python-packaging.inc
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+RDEPENDS_${PN} += "${PYTHON_PN}-six ${PYTHON_PN}-pyparsing"