aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-08 23:18:04 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-09 12:35:15 -0800
commit8c2117626556e0f84a41c8c7d4aa3b2410779ad9 (patch)
tree4274cfde03b06cdc96916fe5c9e37a83fe1c17fc /meta-python
parent75d5263f306becb597a50849a43255df837d089e (diff)
downloadmeta-openembedded-8c2117626556e0f84a41c8c7d4aa3b2410779ad9.tar.gz
python3-httptools: added recipe which is also include ptest
httptools is a Python binding for the nodejs HTTP parser. * Tested on qemux86-64 and qemuarm64 * Add ptest into PTESTS_FAST_META_PYTHON Ptest result: ============= qemux86-64: Testsuite summary TOTAL: 38 PASS: 38 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 10 END: /usr/lib/python3-httptools/ptest 2024-03-08T20:05 STOP: ptest-runner TOTAL: 1 FAIL: 0 qemuarm64: Testsuite summary TOTAL: 38 PASS: 38 SKIP: 0 XFAIL: 0 FAIL: 0 XPASS: 0 ERROR: 0 DURATION: 7 END: /usr/lib/python3-httptools/ptest 2024-03-08T20:08 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-httptools/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-httptools_0.6.1.bb22
3 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index acfe28039c..584fa463ea 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -24,6 +24,7 @@ PTESTS_FAST_META_PYTHON = "\
python3-gpiod \
python3-gunicorn \
python3-html2text \
+ python3-httptools \
python3-inflection \
python3-inotify \
python3-intervals \
diff --git a/meta-python/recipes-devtools/python/python3-httptools/run-ptest b/meta-python/recipes-devtools/python/python3-httptools/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-httptools/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-httptools_0.6.1.bb b/meta-python/recipes-devtools/python/python3-httptools_0.6.1.bb
new file mode 100644
index 0000000000..4192697df2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-httptools_0.6.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A collection of framework independent HTTP protocol utils."
+HOMEPAGE = "https://github.com/MagicStack/httptools"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0a2d82955bf3facdf04cb882655e840e"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI[sha256sum] = "c6e26c30455600b95d94b1b836085138e82f177351454ee841c148f93a9bad5a"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}