aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authoralperak <alperyasinak1@gmail.com>2024-03-08 08:51:35 +0300
committerKhem Raj <raj.khem@gmail.com>2024-03-08 10:07:29 -0800
commit8a69bf4e36f0d013c88fe5a7a97356d2cdc2e191 (patch)
tree694af6c8ecce9f25e3c49e4508561263810462c7 /meta-python
parenta5fd08e401cbfe835206cc3305cb0ce954671aa3 (diff)
downloadmeta-openembedded-8a69bf4e36f0d013c88fe5a7a97356d2cdc2e191.tar.gz
python3-responses: add recipe
A utility library for mocking out the requests Python library. Signed-off-by: alperak <alperyasinak1@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-responses_0.25.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-responses_0.25.0.bb b/meta-python/recipes-devtools/python/python3-responses_0.25.0.bb
new file mode 100644
index 0000000000..f4b59c7506
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-responses_0.25.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A utility library for mocking out the requests Python library."
+HOMEPAGE = "https://github.com/getsentry/responses"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0e601511a8517f4daf688a8eb95be7a2"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "01ae6a02b4f34e39bffceb0fc6786b67a25eae919c6368d05eabc8d9576c2a66"
+
+RDEPENDS:${PN} += " \
+ python3-mock \
+ python3-pyyaml \
+ python3-requests \
+ python3-urllib3 \
+"