aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2021-11-10 12:06:10 +0800
committerKhem Raj <raj.khem@gmail.com>2021-11-11 06:36:05 -0800
commit85eba2f65480cff4f0e273d1d1a46bef695400e1 (patch)
treeea7adfa1d5dfbdf1a357561646ee678521880a1e /meta-python
parentc24ba0d0ef0ddcffca0b89c8ac3279cff9075f12 (diff)
downloadmeta-openembedded-85eba2f65480cff4f0e273d1d1a46bef695400e1.tar.gz
python3-graphviz: upgrade 0.17 -> 0.18
Changelog Version 0.18 Change of beaviour: File endings are now normalized so that all DOT source outputs end with a final newline (Unix convention, simplifies concatenation). This includes DOT source files written by .render(), .view(), or .save() as well was .source generated or loaded from Source (or Source.from_file()). Change of behaviour: Source instances created by Source.from_file() no nonger write the content read into .source back into the file. Use .save(skip_existing=False) before calling .render() or .view() if you want to overwrite the file to produce the previous (less safe) behaviour. Change of undocumented behaviour: When iterating over a Graph, Digraph, or Source instance, the yielded lines now include a final newline ('\n'). This mimics iteration over file object lines in text mode. When passing invalid parameters such as unknown engine, format, etc., .render() now raises early before writing the file. Call .save() explicitly to produce the previous (less safe) behaiour. Add optional keyword-only encoding argument to pipe(). Returns the decoded stdout from the rendering process (e.g. format='svg'). Delegates encoding/decoding to subprocess in the common case (input and output encoding are the same, e.g. default encoding='utf-8'). Used by the Jupyter notebook integration. Add optional keyword-only engine argument to .pipe() and .render(). Add optional keyword-only renderer and formatter arguments to Graph(), Digraph(), Source() and Source.from_file() to set default renderers and formatters (similar to format). Used by .pipe(), .render(), and .view() if not given as method-argument. Add pipe_string(), pipe_lines(), and pipe_lines_string(). Pipe input_string, return string. Pipe input_lines incrementally, return bytes. Pipe input_lines incrementally, return string. Add set_default_engine() and set_default_format() Add backend.DOT_BINARY and backend.UNFLATTEN_BINARY. Restructure the internal class hierarchy using multiple-inheritance with cooperative super() calling: Graph now inherits both from Dot and from Render, and both of them inherit from Base which defines their common interface: Lines of DOT source code that Dot generates (also Source) and rendering iterates over. This might break some undocumented use of subclassing and require adatation Improve test separation. Improve test coverage of running the tests with --skip-exe. Add pytype checking and flake8 to build workflow. Extend type annotations. Add https://mybinder.org config with head development environment. Add launch badge to code repository. Improve documentation and examples. Add development docs. Document release process. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-graphviz_0.18.bb (renamed from meta-python/recipes-devtools/python/python3-graphviz_0.17.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-graphviz_0.17.bb b/meta-python/recipes-devtools/python/python3-graphviz_0.18.bb
index 017a1d0fe6..200292d667 100644
--- a/meta-python/recipes-devtools/python/python3-graphviz_0.17.bb
+++ b/meta-python/recipes-devtools/python/python3-graphviz_0.18.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://graphviz.readthedocs.io/en/stable/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=87cd8818b7e63c6a9c580034e80d7521"
-SRC_URI[sha256sum] = "ef6e2c5deb9cdcc0c7eece1d89625fd07b0f2208ea2bcb483520907ddf8b4e12"
+SRC_URI[sha256sum] = "0f04e5f939d3a839b524283d590e941892c56e75e60e0f5238c431264f490022"
inherit pypi setuptools3