aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-12 17:02:06 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-13 08:06:07 -0700
commit4d94ced1ec43e7c9c0f8a24a5d3a2e7a219a7286 (patch)
treed2de8121bb5dde52bc53a83fcc6ae2acfc821290 /meta-python
parentd46d6e58c26f596fba7cbd739fe8856f89306ab6 (diff)
downloadmeta-openembedded-4d94ced1ec43e7c9c0f8a24a5d3a2e7a219a7286.tar.gz
python3-cerberus: Upgrade 1.3.2 -> 1.3.3
Minor code refactoring of the recipe and upgrade to release 1.3.3: - Classes can be used as constraint for the type rule - The abstract base classes of the standard library's collections.abc module are available as named types for the type rule - Generic type aliases from the :mod:`typing` module can be used as constraints for the type rule, including parametrized ones a.k.a. compound types - Support for Python 3.5 is removed. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb (renamed from meta-python/recipes-devtools/python/python3-cerberus_1.3.2.bb)14
1 files changed, 7 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cerberus_1.3.2.bb b/meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb
index 61a76f5f63..fa0bbb0aad 100644
--- a/meta-python/recipes-devtools/python/python3-cerberus_1.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-cerberus_1.3.3.bb
@@ -1,11 +1,11 @@
-# The PyPI package uses a capital letter so we have to specify this explicitly
-PYPI_PACKAGE = "Cerberus"
-
-inherit pypi setuptools3
-
SUMMARY = "Lightweight, extensible schema and data validation tool for Python dictionaries."
+HOMEPAGE = "http://docs.python-cerberus.org/"
+SECTION = "devel/python"
LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://LICENSE;md5=48f8e9432d0dac5e0e7a18211a0bacdb"
-SRC_URI[md5sum] = "6e648b38b468617a06745d1e8a96c848"
-SRC_URI[sha256sum] = "302e6694f206dd85cb63f13fd5025b31ab6d38c99c50c6d769f8fa0b0f299589"
+# The PyPI package uses a capital letter so we have to specify this explicitly
+PYPI_PACKAGE = "Cerberus"
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "eec10585c33044fb7c69650bc5b68018dac0443753337e2b07684ee0f3c83329"