aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-18 12:03:57 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-18 17:56:15 -0700
commitd82336333e69ec2e9df0dbcb79eae60f0af1522d (patch)
treec1fdd1c20b08162f39cd078816a092237b14271a /meta-python/recipes-devtools
parent7f864d60f208e5e4d80864277095b14a07ae952e (diff)
downloadmeta-openembedded-d82336333e69ec2e9df0dbcb79eae60f0af1522d.tar.gz
python3-periphery: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-periphery.inc9
-rw-r--r--meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb13
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-periphery.inc b/meta-python/recipes-devtools/python/python-periphery.inc
deleted file mode 100644
index 0171f63f83..0000000000
--- a/meta-python/recipes-devtools/python/python-periphery.inc
+++ /dev/null
@@ -1,9 +0,0 @@
-DESCRIPTION = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux."
-HOMEPAGE = "http://pythonhosted.org/python-periphery/"
-LICENSE = "MIT"
-
-LIC_FILES_CHKSUM = "file://PKG-INFO;md5=1ecf5c2354c22fb5bfd53eefb8f9e65b"
-
-PYPI_PACKAGE = "python-periphery"
-
-RDEPENDS_${PN} += "${PYTHON_PN}-mmap"
diff --git a/meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb b/meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb
index e9944274b9..1aa48625ff 100644
--- a/meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb
+++ b/meta-python/recipes-devtools/python/python3-periphery_2.0.1.bb
@@ -1,5 +1,14 @@
-inherit pypi setuptools3
-require python-periphery.inc
+DESCRIPTION = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux."
+HOMEPAGE = "http://pythonhosted.org/python-periphery/"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=1ecf5c2354c22fb5bfd53eefb8f9e65b"
SRC_URI[md5sum] = "1d958f02575d4a19734ee2dd92336157"
SRC_URI[sha256sum] = "5da4d5f40ff8974cf6c724587baa674d7e0593f07b6f6ee896104f11c1be18ec"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "python-periphery"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-mmap"