aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-15 12:38:48 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-16 12:52:19 -0800
commit97c41dcd671efb1497a0128a886ad949b4ceb58d (patch)
treeb18f32b330b3549ac4161e606386ee00fb906ba1 /meta-python/recipes-devtools
parenta14a6159f7a7d3d8301bfa320e4c0fd9b1587e34 (diff)
downloadmeta-openembedded-97c41dcd671efb1497a0128a886ad949b4ceb58d.tar.gz
python3-configparser: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-configparser.inc14
-rw-r--r--meta-python/recipes-devtools/python/python3-configparser_4.0.2.bb16
2 files changed, 14 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-configparser.inc b/meta-python/recipes-devtools/python/python-configparser.inc
deleted file mode 100644
index bce7cee467..0000000000
--- a/meta-python/recipes-devtools/python/python-configparser.inc
+++ /dev/null
@@ -1,14 +0,0 @@
-SUMMARY = "This module provides the ConfigParser class which implements a basic configuration language which provides a structure similar to what's found in Microsoft Windows INI files."
-SECTION = "devel/python"
-HOMEPAGE = "https://docs.python.org/3/library/configparser.html"
-LICENSE = "MIT"
-
-LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=23f9ad5cad3d8cc0336e2a5d8a87e1fa"
-
-SRC_URI[md5sum] = "35926cc4b9133f1f9ca70a1fd2fdf237"
-SRC_URI[sha256sum] = "c7d282687a5308319bf3d2e7706e575c635b0a470342641c93bea0ea3b5331df"
-
-DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
-inherit pypi
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-configparser_4.0.2.bb b/meta-python/recipes-devtools/python/python3-configparser_4.0.2.bb
index 770cba5962..196660925c 100644
--- a/meta-python/recipes-devtools/python/python3-configparser_4.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-configparser_4.0.2.bb
@@ -1,2 +1,14 @@
-inherit setuptools3
-require python-configparser.inc
+SUMMARY = "This module provides the ConfigParser class which implements a basic configuration language which provides a structure similar to what's found in Microsoft Windows INI files."
+SECTION = "devel/python"
+HOMEPAGE = "https://docs.python.org/3/library/configparser.html"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=10;endline=10;md5=23f9ad5cad3d8cc0336e2a5d8a87e1fa"
+
+SRC_URI[md5sum] = "35926cc4b9133f1f9ca70a1fd2fdf237"
+SRC_URI[sha256sum] = "c7d282687a5308319bf3d2e7706e575c635b0a470342641c93bea0ea3b5331df"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"