aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-26 14:29:40 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-29 08:22:33 -0700
commitb52e832261b9b993e90c3ff063274598accb1fad (patch)
tree407e9d1a4db3ade413182baa1956eaa2184f7e4b /meta-python/recipes-devtools/python
parente50907e57ae3e1c6625dfd3077542902e578fd91 (diff)
downloadmeta-openembedded-b52e832261b9b993e90c3ff063274598accb1fad.tar.gz
python3-pkgconfig: Upgrade 1.4.0 -> 1.5.1
Inherit class pypi and upgrade to release 1.5.1: - Use poetry instead of setuptools directly - Fix: raise exception if package is missing - Fix version parsing for openssl-like version numbers - Fix: expose --modversion - Fix: strip whitespace from variable names - Fix: do not specify pytest Python version Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pkgconfig_1.5.1.bb (renamed from meta-python/recipes-devtools/python/python3-pkgconfig_1.4.0.bb)8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pkgconfig_1.4.0.bb b/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.1.bb
index fc7a47a43d..05ca3beecd 100644
--- a/meta-python/recipes-devtools/python/python3-pkgconfig_1.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pkgconfig_1.5.1.bb
@@ -4,16 +4,14 @@ SECTION = "devel/python"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=faa7f82be8f220bff6156be4790344fc"
-SRC_URI = "git://github.com/matze/pkgconfig.git"
-SRCREV ?= "8af0102346847e8873af8e76ab3f34ba9da806e2"
+SRC_URI[md5sum] = "9f9cdb224ec0a1e59efcc7cac4b91972"
+SRC_URI[sha256sum] = "97bfe3d981bab675d5ea3ef259045d7919c93897db7d3b59d4e8593cba8d354f"
RDEPENDS_${PN} = "pkgconfig \
${PYTHON_PN}-shell \
"
-inherit setuptools3
-
-S = "${WORKDIR}/git"
+inherit pypi setuptools3
BBCLASSEXTEND = "native"