aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-02 22:29:02 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-02 23:14:36 -0700
commita8b2cdc20e184365701bcd8316956fd3fabf6425 (patch)
tree45ffbf9a16e5268b26e1f6e3296ba7b37d6696a8 /meta-python/recipes-devtools/python
parent3b82b10eec885330dd56de8dfe8223d4721129c2 (diff)
downloadmeta-openembedded-a8b2cdc20e184365701bcd8316956fd3fabf6425.tar.gz
python3-pydbus: Add bash dependency for ptests
ptest script uses bash Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb b/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
index 7962c4322b..7399ae1a01 100644
--- a/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
@@ -20,6 +20,8 @@ RDEPENDS:${PN} = "python3-pygobject \
python3-io \
python3-logging"
+RDEPENDS:${PN}-ptests = "bash"
+
do_install_ptest() {
install -d ${D}${PTEST_PATH}/tests
cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/