aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-07-17 03:43:20 +0800
committerKhem Raj <raj.khem@gmail.com>2020-07-16 12:10:43 -0700
commit70e7be04979a9346518b66656053be48b74040af (patch)
treee1ef2fa9933e7f5e598a4605bd8c97de66bcede9 /meta-python/recipes-devtools/python
parent2c2c5ea042be2a453984c7bd456b2e4e97b7ac33 (diff)
downloadmeta-openembedded-70e7be04979a9346518b66656053be48b74040af.tar.gz
python3-typeguard: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb17
2 files changed, 19 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typeguard/run-ptest b/meta-python/recipes-devtools/python/python3-typeguard/run-ptest
new file mode 100644
index 0000000000..b63c4de0d9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-typeguard/run-ptest
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb b/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb
index a0167cf03b..3786ccb855 100644
--- a/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb
+++ b/meta-python/recipes-devtools/python/python3-typeguard_2.9.1.bb
@@ -6,7 +6,22 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=f0e423eea5c91e7aa21bdb70184b3e53"
SRC_URI[md5sum] = "411df8eefd76ffa014328a46342bdf38"
SRC_URI[sha256sum] = "529ef3d88189cc457f4340388028412f71be8091c2c943465146d4170fb67288"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-typing-extensions \
+ ${PYTHON_PN}-unixadmin \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
DEPENDS += "\
python3-distutils-extra-native \