aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2023-12-18 19:09:00 +0200
committerKhem Raj <raj.khem@gmail.com>2023-12-18 22:17:25 -0800
commit1d887eede793e8e3da3a75f3ffead7ea1d867698 (patch)
treefdad1d19475ba894197e093955f6be6515475e92 /meta-python/recipes-devtools/python
parentc6ba2fcc4a46cf8df0060d1dc90d4b6864cb6140 (diff)
downloadmeta-openembedded-1d887eede793e8e3da3a75f3ffead7ea1d867698.tar.gz
python3-dominate: upgrade 2.8.0 -> 2.9.0
Upgrade to version 2.9.0: - Modernize setuptools support to use pyproject.toml - Remove brittle test Remove fix-ptests.patch as the issue has been solved upstream. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch20
-rw-r--r--meta-python/recipes-devtools/python/python3-dominate_2.9.0.bb (renamed from meta-python/recipes-devtools/python/python3-dominate_2.8.0.bb)5
2 files changed, 2 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch b/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch
deleted file mode 100644
index 81211d4498..0000000000
--- a/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Fixes test failures on musl
-
-Fixes errors
-ptestresult.python3-dominate.tests/test_dom_tag.py::test___get_thread_context
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-
-diff --git a/tests/test_dom_tag.py b/tests/test_dom_tag.py
-index 43ffecb..1126e54 100644
---- a/tests/test_dom_tag.py
-+++ b/tests/test_dom_tag.py
-@@ -18,6 +18,7 @@ def test___get_thread_context(monkeypatch):
- monkeypatch.setattr(sut, 'threading', threading)
-
- assert sut._get_thread_context() in [
-+ 1692341442, # Python >= 3.9, 32-bit
- -6805948436281256182, # Python >= 3.9
- 3713141171098444831, # Python < 3.9
- ]
diff --git a/meta-python/recipes-devtools/python/python3-dominate_2.8.0.bb b/meta-python/recipes-devtools/python/python3-dominate_2.9.0.bb
index 6b0489e4fd..2234e541b7 100644
--- a/meta-python/recipes-devtools/python/python3-dominate_2.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dominate_2.9.0.bb
@@ -2,13 +2,12 @@ SUMMARY = "Dominate is a Python library for creating and manipulating HTML docum
LICENSE = "LGPL-3.0-only"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
-SRC_URI[sha256sum] = "4c90c3befaf88e612b71f4b39af7bcbef8977acfa855cec957225a8fbf504007"
+SRC_URI[sha256sum] = "b15791ebea432218543a1702d76ae45d2ff95ff994e52014b8686a69dad772fd"
-inherit pypi setuptools3 ptest
+inherit pypi ptest python_setuptools_build_meta
SRC_URI += " \
file://run-ptest \
- file://fix-ptests.patch \
"
RDEPENDS:${PN}-ptest += " \