aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-urllib3_1.25.9.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-09 14:10:48 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-10 20:56:17 -0700
commitdb52e1415120bc27b6b2454decf61d6047bcdd95 (patch)
tree692fcf860a895567afa39fca25042f24fd43aebf /meta-python/recipes-devtools/python/python3-urllib3_1.25.9.bb
parentc7f63a9758632c0641159251a6901fdaca8d506d (diff)
downloadmeta-openembedded-db52e1415120bc27b6b2454decf61d6047bcdd95.tar.gz
python3-urllib3: Upgrade 1.25.7 -> 1.25.9
Upgrade to release 1.25.9. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-urllib3_1.25.9.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-urllib3_1.25.9.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-urllib3_1.25.9.bb b/meta-python/recipes-devtools/python/python3-urllib3_1.25.9.bb
new file mode 100644
index 0000000000..8cbc1f9f9d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-urllib3_1.25.9.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Python HTTP library with thread-safe connection pooling, file post support, sanity friendly, and more"
+HOMEPAGE = "https://github.com/shazow/urllib3"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=65715c2eb961313d71b297dd5a04f85e"
+
+SRC_URI[md5sum] = "dbf9b868b90880b24b1ac278094e912e"
+SRC_URI[sha256sum] = "3018294ebefce6572a474f0604c2021e33b3fd8006ecd11d62107a5d2a963527"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-certifi \
+ ${PYTHON_PN}-cryptography \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-idna \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-threading \
+"
+
+CVE_PRODUCT = "urllib3"
+
+BBCLASSEXTEND = "native nativesdk"