aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-tzlocal_4.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-11-08 12:42:34 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-09 06:52:28 -0800
commit0492d258ced2b113167157fa0e314864d2b20893 (patch)
tree67cbbe4224012ba20b7f26a3d84e9f169fa76b93 /meta-python/recipes-devtools/python/python3-tzlocal_4.1.bb
parenta20383dec28fd5f0c25290341d50ac82c740c736 (diff)
downloadmeta-openembedded-0492d258ced2b113167157fa0e314864d2b20893.tar.gz
python3-tzlocal: Upgrade 4.0.1 -> 4.1
Upgrade to release 4.1: - It turns out a lot of Linux distributions make the links between zoneinfo aliases backwards, so instead of linking GB to Europe/London it actually links the other way. When /etc/localtime then links to Europe/London, and you also have a config file saying Europe/London, the code that checks if /etc/localtime is a symlink ends up at GB instead of Europe/London and we get an error, as it thinks GB and Europe/London are different zones. So now we check the symlink of all timezones in the uniqueness test. We still return the name in the config file, though, so you would only get GB or Zulu returned as the time zone instead of Europe/London or UTC if your only configuration is the /etc/localtime symlink, as that's checked last, and tzlocal will return the first configuration found. - The above change also means that GMT and UTC are no longer seen as synonyms, as zoneinfo does not see them as synonyms. This might be controversial, but you just have to live with it. Pick one and stay with it. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-tzlocal_4.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-tzlocal_4.1.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tzlocal_4.1.bb b/meta-python/recipes-devtools/python/python3-tzlocal_4.1.bb
new file mode 100644
index 0000000000..29a69f8b8f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-tzlocal_4.1.bb
@@ -0,0 +1,12 @@
+SUMMARY = "Library to return tzinfo with the local timezone information"
+HOMEPAGE = "https://pypi.org/project/tzlocal/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=57e0bd61643d81d05683cdce65b11d10"
+
+SRC_URI[sha256sum] = "0f28015ac68a5c067210400a9197fc5d36ba9bc3f8eaf1da3cbd59acdfed9e09"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-pytz-deprecation-shim \
+"