aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-socketio_4.6.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-25 12:07:10 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-26 08:56:04 -0700
commit2363f73e47ec58e8fb243cdc203a2b5658014d9c (patch)
tree99feb9aa1825b91f8b299b6b11e9e68fb99ce835 /meta-python/recipes-devtools/python/python3-socketio_4.6.0.bb
parent639bd42e8f4e51efe1c34c6013168a957e1821d0 (diff)
downloadmeta-openembedded-2363f73e47ec58e8fb243cdc203a2b5658014d9c.tar.gz
python3-socketio: Upgrade 4.5.1 -> 4.6.0
Upgrade to release 4.6.0: - Improved handling of rejected connections - Fix multi-namespace disconnect logic - AsyncPubSubManager does not await for can_disconnect() - Require a recipient in call() function in the server - ASGI startup and shutdown lifespan handlers - Remove references to Python 2.7 in the documentation - Fix server example in docstring - Fix documentation typo Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-socketio_4.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-socketio_4.6.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-socketio_4.6.0.bb b/meta-python/recipes-devtools/python/python3-socketio_4.6.0.bb
new file mode 100644
index 0000000000..7d96398e95
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-socketio_4.6.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Socket.IO server"
+HOMEPAGE = "https://github.com/miguelgrinberg/python-socketio/"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=42d0a9e728978f0eeb759c3be91536b8"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "python-socketio"
+
+SRC_URI[md5sum] = "44bb7854234e144655ef9c34b0165704"
+SRC_URI[sha256sum] = "358d8fbbc029c4538ea25bcaa283e47f375be0017fcba829de8a3a731c9df25a"
+
+PACKAGECONFIG ?= "asyncio_client client"
+PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets"
+PACKAGECONFIG[client] = ",,,${PYTHON_PN}-requests ${PYTHON_PN}-websocket-client"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-engineio \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-attrs \
+ "