aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.10.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-25 12:07:14 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-26 08:56:18 -0700
commit465426ebce5bcc5f6541e3fcc91cc5e8b2b8976b (patch)
tree6f4b0fab27da48fff7f9fafc32e7714c705d1788 /meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.10.bb
parentfa3e364a518778cfa6ef41d36612e744481882bc (diff)
downloadmeta-openembedded-465426ebce5bcc5f6541e3fcc91cc5e8b2b8976b.tar.gz
python3-ruamel-yaml: Upgrade 0.16.5 0> 0.16.10
Upgrade to release 0.16.10: - updated image references in README to sourceforge - update requirements so that ruamel.yaml.clib is installed for 3.8, as it has become available - fix typchecking issue on TaggedScalar - fix error in dumping literal scalar in sequence with comments before element - fix empty string mapping key roundtripping with preservation of quotes as `? ''` - fix incorrect state setting in class constructor - adjust deprecation warning test for Hashable, as that no longer warns The year in LICENSE has been updated and LIC_FILES_CHKSUM changed. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.10.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.10.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.10.bb b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.10.bb
new file mode 100644
index 0000000000..076721a09d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ruamel-yaml_0.16.10.bb
@@ -0,0 +1,16 @@
+SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
+AUTHOR = "Anthon van der Neut"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=60afc0a1bb0501c0c555cabe78bba022"
+
+PYPI_PACKAGE = "ruamel.yaml"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "02774e7ed3273b3d8eee6c08326b91c4"
+SRC_URI[sha256sum] = "099c644a778bf72ffa00524f78dd0b6476bca94a1da344130f4bf3381ce5b954"
+
+do_install_prepend() {
+ export RUAMEL_NO_PIP_INSTALL_CHECK=1
+}