aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-requests_2.23.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 13:29:10 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:13 -0700
commit2fa9ae6fa68947dcb74caf342253d0918161e49c (patch)
tree8f626f2510dbbbc8dff0b68d184978071a133809 /meta-python/recipes-devtools/python/python3-requests_2.23.0.bb
parenta2b25b8a0e47ea73b933ccb082cd9fbf5e507a84 (diff)
downloadmeta-openembedded-2fa9ae6fa68947dcb74caf342253d0918161e49c.tar.gz
python-requests: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-requests_2.23.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-requests_2.23.0.bb30
1 files changed, 28 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-requests_2.23.0.bb b/meta-python/recipes-devtools/python/python3-requests_2.23.0.bb
index 0a2410f85c..9f3fb7d2e9 100644
--- a/meta-python/recipes-devtools/python/python3-requests_2.23.0.bb
+++ b/meta-python/recipes-devtools/python/python3-requests_2.23.0.bb
@@ -1,2 +1,28 @@
-inherit setuptools3
-require python-requests.inc
+DESCRIPTION = "Python HTTP for Humans."
+HOMEPAGE = "http://python-requests.org"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=19b6be66ed463d93fa88c29f7860bcd7"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/python-requests:"
+
+SRC_URI[md5sum] = "abfdc28db1065bbd0bc32592ac9d27a6"
+SRC_URI[sha256sum] = "b3f43d496c6daba4493e7c431722aeb7dbc6288f52a6e04e7b6023b0247817e6"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-email \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-ndg-httpsclient \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-pyasn1 \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-pysocks \
+ ${PYTHON_PN}-urllib3 \
+ ${PYTHON_PN}-chardet \
+ ${PYTHON_PN}-idna \
+"
+
+CVE_PRODUCT = "requests"
+
+BBCLASSEXTEND = "native nativesdk"