aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2020-04-21 13:37:35 +0800
committerKhem Raj <raj.khem@gmail.com>2020-04-21 07:14:06 -0700
commit7e372d1676c2afba3f248db6459a03a30a63ae9f (patch)
tree1349729fed902d4f46b601567df130d748854248 /meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
parente455fb50f86a391cef8acdafe05f27968536303e (diff)
downloadmeta-openembedded-7e372d1676c2afba3f248db6459a03a30a63ae9f.tar.gz
python3-pytz: Enable ptest
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytz_2019.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytz_2019.3.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb b/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
index ffe336d2c3..c28a0148bc 100644
--- a/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://pythonhosted.org/pytz"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4878a915709225bceab739bdc2a18e8d"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
SRC_URI[md5sum] = "c3d84a465fc56a4edd52cca8873ac0df"
SRC_URI[sha256sum] = "b02c06db6cf09c12dd25137e563b31700d3b80fcc4ad23abb7a315f2789819be"
@@ -18,3 +18,19 @@ RDEPENDS_${PN}_class-target += "\
"
BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/pytz
+ install -d ${D}${PTEST_PATH}/pytz/tests
+ cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
+ cp -f ${S}/README.txt ${D}${PTEST_PATH}/
+
+}