aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 14:21:00 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit474f362bfed90e998dcc7f24431b984e7411e571 (patch)
treececb5fb6b16678aaedcc76300cf473ebde10f1cb /meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
parent9d300f9d03ec8a0762d21902f5100b92984600eb (diff)
downloadmeta-openembedded-474f362bfed90e998dcc7f24431b984e7411e571.tar.gz
python-pytz: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pytz_2019.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pytz_2019.3.bb22
1 files changed, 20 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb b/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
index 19a89dc55d..ffe336d2c3 100644
--- a/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pytz_2019.3.bb
@@ -1,2 +1,20 @@
-inherit setuptools3
-require python-pytz.inc
+SUMMARY = "World timezone definitions, modern and historical"
+HOMEPAGE = "http://pythonhosted.org/pytz"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4878a915709225bceab739bdc2a18e8d"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "c3d84a465fc56a4edd52cca8873ac0df"
+SRC_URI[sha256sum] = "b02c06db6cf09c12dd25137e563b31700d3b80fcc4ad23abb7a315f2789819be"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"