aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-08 15:14:10 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-11 07:44:11 -0700
commit5cc970c1d87fbde9e1c8261fa0edcd71d2e89b96 (patch)
tree78b1a281ae90a23e4b3424e38de03d60915c7dd2 /meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
parent14c04f49751ed6490a47a009a9851690dae4c85b (diff)
downloadmeta-openembedded-5cc970c1d87fbde9e1c8261fa0edcd71d2e89b96.tar.gz
python3-prettytable: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Inherit pypi. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb38
1 files changed, 36 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb b/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
index 5445f10192..18f3390619 100644
--- a/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
+++ b/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
@@ -1,3 +1,37 @@
-inherit setuptools3
-require python-prettytable.inc
+SUMMARY = "Python library for displaying tabular data in a ASCII table format"
+HOMEPAGE = "http://code.google.com/p/prettytable"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
+SRC_URI[md5sum] = "a6b80afeef286ce66733d54a0296b13b"
+SRC_URI[sha256sum] = "2d5460dc9db74a32bcc8f9f67de68b2c4f4d2f01fa3bd518764c69156d9cacd9"
+
+do_install_append() {
+ perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
+ for f in $perm_files; do
+ chmod 644 "${f}"
+ done
+}
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
+UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
+
+BBCLASSEXTEND = "native nativesdk"
+inherit pypi ptest setuptools3
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-math \
+ ${PYTHON_PN}-html \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/prettytable_test.py ${D}${PTEST_PATH}/
+}