aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ply_3.11.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-11 12:09:02 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-11 21:58:29 -0700
commit131d7d04b421a35b4e7382f58535c5e91da55f6b (patch)
treedc9f8892b66d1230d8115f59f3da476d996cc972 /meta-python/recipes-devtools/python/python3-ply_3.11.bb
parent3e8ffc30fbd33823954896c52c8f1353bb468bea (diff)
downloadmeta-openembedded-131d7d04b421a35b4e7382f58535c5e91da55f6b.tar.gz
python3-ply: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ply_3.11.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ply_3.11.bb20
1 files changed, 18 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ply_3.11.bb b/meta-python/recipes-devtools/python/python3-ply_3.11.bb
index 72410baebf..3aa010fac3 100644
--- a/meta-python/recipes-devtools/python/python3-ply_3.11.bb
+++ b/meta-python/recipes-devtools/python/python3-ply_3.11.bb
@@ -1,2 +1,18 @@
-require python-ply.inc
-inherit setuptools3
+SUMMARY = "Python Lex and Yacc"
+DESCRIPTION = "Python ply: PLY is yet another implementation of lex and yacc for Python"
+HOMEPAGE = "https://pypi.python.org/pypi/ply"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://README.md;beginline=5;endline=32;md5=f5ee5c355c0e6719c787a71b8f0fa96c"
+
+SRC_URI[md5sum] = "6465f602e656455affcd7c5734c638f8"
+SRC_URI[sha256sum] = "00c7c1aaa88358b9c765b6d3000c6eec0ba42abca5351b095321aef446081da3"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native"