aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pint_0.13.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-23 12:51:35 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-25 10:21:38 -0700
commitc5a3d25c10e9f1d3ffbe50a9e760644acdb9cd0b (patch)
treea116f8c656bc38d7cbcd9f3f8db21a035ffc302a /meta-python/recipes-devtools/python/python3-pint_0.13.bb
parentb2bab59b880ff46ca7d52584367d73c4e78c89eb (diff)
downloadmeta-openembedded-c5a3d25c10e9f1d3ffbe50a9e760644acdb9cd0b.tar.gz
python3-pint: Upgrade 0.12 -> 0.13
Upgrade to release 0.13: - Reinstated support for pickle protocol 0 and 1, which is required by pytables - Fixed bug with multiplication of Quantity by dict - Bare zeros and NaNs (not wrapped by Quantity) are now gracefully accepted by all numpy operations; e.g. np.stack ([Quantity([1, 2], "m"), [0, np.nan]) is now valid, whereas np.stack([Quantity([1, 2], "m"), [3, 4]) will continue raising DimensionalityError. - NaN is now treated the same as zero in addition, subtraction, equality, and disequality - Fixed issue where quantities with a very large magnitude would throw an IndexError when using to_compact() - Fixed crash when a Unit with prefix is declared for the first time while a Context containing unit redefinitions is active - New implementation of 'Lx' String Format Type Option The old implementation treated 'Lx' as 'S' as produced by 'uncertainties' package, but that is not fully compatible with SIunitx. The new code protects SIunitx by fixing what unceratinties produces. - Added link to budding `pint-xarray` interface library to the docs, next to the link to pint-pandas. - Removed outdated `_dir` attribute of `UnitsRegistry`, and added `__iter__` method so that now `list(ureg)` returns a list of all units in registry. - Replace pkg_resources.version to importlib.metadata.version. - Fix typo in docs for wraps example with optional arguments. - Add momentum as a dimension - Fixed a bug where unit exponents were only partially superscripted in HTML format - Multiple contexts containing the same redefinition can now be stacked - Fixed crash when some specific combinations of contexts were enabled - Added support for checking prefixed units using `in` keyword - Updated many examples in the documentation to reflect Pint's current behavior Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pint_0.13.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pint_0.13.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.13.bb b/meta-python/recipes-devtools/python/python3-pint_0.13.bb
new file mode 100644
index 0000000000..9a081babab
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pint_0.13.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Physical quantities module"
+DESCRIPTION = "Physical quantities Python module"
+HOMEPAGE = "https://github.com/hgrecco/pint"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
+
+PYPI_PACKAGE := "Pint"
+
+inherit pypi ptest setuptools3
+
+SRC_URI[md5sum] = "6e60d42736f8175a57119aecc383fe4b"
+SRC_URI[sha256sum] = "13fa35ffa3ddf53161b4304917085687950e0de461bcdd4d65cdee11a43d7fb2"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/testsuite
+ cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
+}