aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-18 12:03:58 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-18 17:56:19 -0700
commit3c7c324e4e6f1659971169717bda7b91c66ec1c7 (patch)
tree9ce42b78379e7f2bf531a512c40f12ae1b8bd4aa /meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb
parentd82336333e69ec2e9df0dbcb79eae60f0af1522d (diff)
downloadmeta-openembedded-3c7c324e4e6f1659971169717bda7b91c66ec1c7.tar.gz
python3-periphery: Upgrade 2.0.1 -> 2.1.0
Upgrade to release 2.1.0. Use LICENSE instead of PKG-INFO in LIC_FILES_CHKSUM. The new release brings the following changes: GPIO: - Add poll_multiple() static method. - Add line consumer label property. - Add line bias, line drive, and inverted properties. - Add additional properties as keyword arguments to constructor for character device GPIOs. - Only unexport GPIO in close() if exported in open for sysfs GPIOs. - Improve wording and fix typos in docstrings. Serial: - Fix performance of blocking read in read(). - Raise exception on unexpected empty read in read(), which may be caused by a serial port disconnect. - Add vmin and vtime properties for the corresponding termios settings. - Add support for termios timeout with read(). - Improve wording in docstrings. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb b/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb
new file mode 100644
index 0000000000..3cd9004dff
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-periphery_2.1.0.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux."
+HOMEPAGE = "http://pythonhosted.org/python-periphery/"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fea92e2e010ccb151792c29fadc2db7b"
+
+SRC_URI[md5sum] = "27cdd7e026438067a238fb04ed5766a3"
+SRC_URI[sha256sum] = "57baa82e6bc59b67747317d16ad0cf9626826e8d43233af13bce924660500bd6"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "python-periphery"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-mmap"