aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-25 12:07:16 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-26 08:56:26 -0700
commit243bfe4eb9a45e2a6ea9d11087fda13da956ac87 (patch)
tree1648c3feb4e054373388bea76e0169ae9afa2fc3 /meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb
parent5dbc25ea9d4bd4b3f9a150d3893a12b41dd456d3 (diff)
downloadmeta-openembedded-243bfe4eb9a45e2a6ea9d11087fda13da956ac87.tar.gz
python3-matplotlib: Upgrade 3.2.1 -> 3.2.2
Upgrade to release 3.2.2: - Unit converters recognize subclasses - imsave accepts metadata and PIL options - cbook.normalize_kwargs - FontProperties accepts os.PathLike - Gouraud-shading alpha channel in PDF backend - Kerning adjustments now use correct values - bar3d lightsource shading - Shifting errorbars - Improvements in Logit scale ticker and formatter - rcParams for axes title location and color - 3-digit and 4-digit hex colors The line in setup.py for determining the license has changed. The license remains the same. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb
new file mode 100644
index 0000000000..b32177d9b4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.2.2.bb
@@ -0,0 +1,37 @@
+SUMMARY = "matplotlib: plotting with Python"
+DESCRIPTION = "\
+Matplotlib is a Python 2D plotting library which produces \
+publication-quality figures in a variety of hardcopy formats \
+and interactive environments across platforms."
+HOMEPAGE = "https://github.com/matplotlib/matplotlib"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "\
+ file://setup.py;beginline=253;endline=253;md5=2a114620e4e6843aa7568d5902501753 \
+ file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
+"
+DEPENDS = "\
+ freetype \
+ libpng \
+ python3-numpy-native \
+ python3-dateutil-native \
+ python3-pytz-native \
+"
+
+SRC_URI[md5sum] = "b60cd68f792a30173d825e16482aedd8"
+SRC_URI[sha256sum] = "3d77a6630d093d74cbbfebaa0571d00790966be1ed204e4a8239f5cbd6835c5d"
+
+inherit pypi setuptools3 pkgconfig
+
+RDEPENDS_${PN} = "\
+ freetype \
+ libpng \
+ python3-numpy \
+ python3-pyparsing \
+ python3-cycler \
+ python3-dateutil \
+ python3-kiwisolver \
+ python3-pytz \
+"
+
+BBCLASSEXTEND = "native"