aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-10 16:15:32 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-11 07:43:08 -0700
commit21e355fd0396ab51ee2f3723475806afdfce0fcf (patch)
tree4a8d16362f628dc3691d72845543e5bbea7cd8f0 /meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb
parent39d777ab4702eafe339d0f9b55f07a102d77bb93 (diff)
downloadmeta-openembedded-21e355fd0396ab51ee2f3723475806afdfce0fcf.tar.gz
python3-markupsafe: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb29
1 files changed, 27 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb b/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb
index 765e3c906b..7de57cbd63 100644
--- a/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-markupsafe_1.1.1.bb
@@ -1,2 +1,27 @@
-inherit setuptools3
-require python-markupsafe.inc
+DESCRIPTION = "Implements a XML/HTML/XHTML Markup safe string for Python"
+HOMEPAGE = "http://github.com/mitsuhiko/markupsafe"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75"
+
+SRC_URI[md5sum] = "43fd756864fe42063068e092e220c57b"
+SRC_URI[sha256sum] = "29872e92839765e546828bb7754a68c418d927cd064fd4708fab9fe9c8bb116b"
+
+PYPI_PACKAGE = "MarkupSafe"
+inherit pypi ptest setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-stringold"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -f ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}