aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-luma-oled_3.4.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-04-06 11:31:50 +0300
committerKhem Raj <raj.khem@gmail.com>2020-04-06 08:29:49 -0700
commita6e097dbc6f17222cc37f3a6d4f8769fa6f71e62 (patch)
tree41da4d8c67e63612a1cca7a8ada7cb56fe3694f2 /meta-python/recipes-devtools/python/python3-luma-oled_3.4.0.bb
parentf58a6b6b788c6b8fd6275ba94ad1bd6b329dc480 (diff)
downloadmeta-openembedded-a6e097dbc6f17222cc37f3a6d4f8769fa6f71e62.tar.gz
python-luma-oled: add new recipe
Python library interfacing OLED matrix displays with the SSD1306, SSD1309, SSD1322, SSD1325, SSD1327, SSD1331, SSD1351 or SH1106 driver using I2C/SPI on the Raspberry Pi and other single-board computers. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-luma-oled_3.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-luma-oled_3.4.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-luma-oled_3.4.0.bb b/meta-python/recipes-devtools/python/python3-luma-oled_3.4.0.bb
new file mode 100644
index 0000000000..ee3b00e7fd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-luma-oled_3.4.0.bb
@@ -0,0 +1,20 @@
+SUMMARY = "A small library to drive an OLED device"
+DESCRIPTION = "\
+A small library to drive an OLED device with either SSD1306 , SSD1309, SSD1322, \
+SSD1325, SSD1327, SSD1331, SSD1351 or SH1106 chipset"
+HOMEPAGE = "https://github.com/rm-hull/luma.oled"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=c328c862c3335ad464e1c9a3ba574249"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "2944155b2242b9d2ddeb6e139c6083b8"
+SRC_URI[sha256sum] = "2ea2b535e7e2f056a51a8c54ad78aa1f00d5699fc439c01bc7c2902823889552"
+
+CLEANBROKEN = "1"
+
+PYPI_PACKAGE = "luma.oled"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-luma-core \
+"