aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.2.bb
diff options
context:
space:
mode:
authorNicola Lunghi <nick83ola@gmail.com>2020-01-13 09:50:05 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-13 18:34:32 -0800
commitace72cb043184e2b4dd3811eb80e1a461309de64 (patch)
tree8e67162ccb8a9aeab3f992882a04074d787f573b /meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.2.bb
parentd93a18e9bf34bf4a2e3b02b27cb982773a6c3691 (diff)
downloadmeta-openembedded-ace72cb043184e2b4dd3811eb80e1a461309de64.tar.gz
python3-jsonrpcserver: update to 4.1.2
this release solve the permission issue on the EGG directory Signed-off-by: Nicola Lunghi <nick83ola@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.2.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.2.bb b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.2.bb
new file mode 100644
index 0000000000..e23720c3ed
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonrpcserver_4.1.2.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Library to process JSON-RPC requests"
+HOMEPAGE = "https://github.com/bcb/jsonrpcserver"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=c89120516900f96f4c60d35fdc4c3f15"
+
+SRC_URI[md5sum] = "fd4091bc19eb18579c15b97af70714eb"
+SRC_URI[sha256sum] = "73db55d1cf245ebdfb96ca05c4cce01c51b61be845a2a981f539ea1e6a4e0c4a"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ python3-apply-defaults \
+ python3-asyncio \
+ python3-core \
+ python3-json \
+ python3-jsonschema \
+ python3-logging \
+ python3-netclient \
+ python3-pkgutil \
+ python3-typing \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+