aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jsonpointer_2.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-15 10:47:20 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-17 12:04:38 -0700
commit09fa34b9c7a460e60bd49cd6a2fcc7711a725993 (patch)
tree525a1e93ba17b59374c380c2267143cda61f6382 /meta-python/recipes-devtools/python/python3-jsonpointer_2.1.bb
parent593ca57bbc30f33cd310ef517646eb1571d6e6f5 (diff)
downloadmeta-openembedded-09fa34b9c7a460e60bd49cd6a2fcc7711a725993.tar.gz
python3-jsonpointer: Upgrade 2.0 -> 2.1
Upgrade to release 2.1: - Support Python 3.8 and 3.9 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jsonpointer_2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonpointer_2.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonpointer_2.1.bb b/meta-python/recipes-devtools/python/python3-jsonpointer_2.1.bb
new file mode 100644
index 0000000000..a4cc05c947
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-jsonpointer_2.1.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Resolve JSON Pointers in Python"
+HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
+
+inherit pypi ptest setuptools3
+
+SRC_URI[sha256sum] = "5a34b698db1eb79ceac454159d3f7c12a451a91f6334a4f638454327b7a89962"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/tests.py ${D}${PTEST_PATH}/
+}