aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-05-13 16:23:25 +0300
committerKhem Raj <raj.khem@gmail.com>2021-05-14 07:25:05 -0700
commitad8a4ff11c1e830126524758cac74d00f10caf4a (patch)
tree9c01c3671352bed01ababad61a1a804e3f147bb3 /meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb
parenta7ea64f010ed286e4693692a28e5b3344b43792d (diff)
downloadmeta-openembedded-ad8a4ff11c1e830126524758cac74d00f10caf4a.tar.gz
python3-itsdangerous: Upgrade 1.1.0 -> 2.0.0
Upgrade to release 2.0.0: - Drop support for Python 2 and 3.5. - JWS support (JSONWebSignatureSerializer, TimedJSONWebSignatureSerializer) is deprecated. Use a dedicated JWS/JWT library such as authlib instead. - Importing itsdangerous.json is deprecated. Import Python’s json module instead. - Simplejson is no longer used if it is installed. To use a different library, pass it as Serializer(serializer=...). - datetime values are timezone-aware with timezone.utc. Code using TimestampSigner.unsign(return_timestamp=True) or BadTimeSignature.date_signed may need to change. - If a signature has an age less than 0, it will raise SignatureExpired rather than appearing valid. This can happen if the timestamp offset is changed. - BadTimeSignature.date_signed is always a datetime object rather than an int in some cases. - Added support for key rotation. A list of keys can be passed as secret_key, oldest to newest. The newest key is used for signing, all keys are tried for unsigning. - Removed the default SHA-512 fallback signer from default_fallback_signers. - Add type information for static typing tools. License-Update: standardize license Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb17
1 files changed, 0 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb b/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb
deleted file mode 100644
index 7f50641c89..0000000000
--- a/meta-python/recipes-devtools/python/python3-itsdangerous_1.1.0.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-SUMMARY = "Various helpers to pass trusted data to untrusted environments and back."
-HOMEPAGE = "http://github.com/mitsuhiko/itsdangerous"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=370799bf709a1e4a6a369fa089ac73a6"
-
-SRC_URI[md5sum] = "9b7f5afa7f1e3acfb7786eeca3d99307"
-SRC_URI[sha256sum] = "321b033d07f2a4136d3ec762eac9f16a10ccd60f53c0c91af90217ace7ba1f19"
-
-inherit pypi setuptools3
-
-CLEANBROKEN = "1"
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-simplejson \
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-compression \
-"