aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-03 14:16:29 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-05 18:42:38 -0700
commitfb64ee5c12c340ac796ff0fe69d7a81f490a7b95 (patch)
tree8b692827e8a318500aaeeba32d7908db7b6dd51a /meta-python/recipes-devtools/python/python3-isort_4.3.21.bb
parentf1919b7e1c5ce6562715b801f6051721af6db259 (diff)
downloadmeta-openembedded-fb64ee5c12c340ac796ff0fe69d7a81f490a7b95.tar.gz
python3-isort: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-isort_4.3.21.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-isort_4.3.21.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb b/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb
index 755b3e2f23..e0b21ab554 100644
--- a/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb
+++ b/meta-python/recipes-devtools/python/python3-isort_4.3.21.bb
@@ -1,2 +1,17 @@
-inherit setuptools3
-require python-isort.inc
+SUMMARY = "A Python utility / library to sort Python imports."
+HOMEPAGE = "https://pypi.python.org/pypi/isort"
+LICENSE = "MIT"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=8227180126797a0148f94f483f3e1489"
+
+SRC_URI[md5sum] = "05d66f2eb7ce2c2d702e86bac24bf9e4"
+SRC_URI[sha256sum] = "54da7e92468955c4fceacd0c86bd0ec997b0e1ee80d97f67c35a78b719dccab1"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"