aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-08 15:14:06 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-11 07:43:48 -0700
commit5f3eb7cd6dc293a8ebecfcda36fdaa19f8097f91 (patch)
treed98c93f307745583cbf86e9ed16a8e5236d34adf /meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb
parentc1123ba2327571f036b9a6b3622af53c5c732236 (diff)
downloadmeta-openembedded-5f3eb7cd6dc293a8ebecfcda36fdaa19f8097f91.tar.gz
python3-hyperlink: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb19
1 files changed, 17 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb b/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb
index 70813bf34c..3ee098ad6b 100644
--- a/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-hyperlink_19.0.0.bb
@@ -1,2 +1,17 @@
-inherit setuptools3
-require python-hyperlink.inc
+DESCRIPTION = "A featureful, correct URL for Python"
+HOMEPAGE = "https://github.com/python-hyper/hyperlink"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3893d4ed05dcc823f8ed685a9ea19bcb"
+
+SRC_URI[sha256sum] = "4288e34705da077fada1111a24a0aa08bb1e76699c9ce49876af722441845654"
+SRC_URI[md5sum] = "4772fb4d87c26a1ab22a6161424e3cba"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-stringold ${PYTHON_PN}-netclient ${PYTHON_PN}-idna"
+
+PACKAGES =. "${PN}-test "
+
+FILES_${PN}-test += " \
+ ${PYTHON_SITEPACKAGES_DIR}/hyperlinkt/test \
+"