aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-29 20:18:52 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-03 18:06:51 -0700
commit11830057f445ed6643b9c9d6f4ce38aa76ad1043 (patch)
tree499e5f60e2253f6beb1b18184cd2ee73f7eb5afe /meta-python/recipes-devtools/python/python3-html5lib_1.1.bb
parentdac0ee3ad59fc04af0138dfb122828318cdae553 (diff)
downloadmeta-openembedded-11830057f445ed6643b9c9d6f4ce38aa76ad1043.tar.gz
python3-html5lib: Upgrade 1.0.1 -> 1.1
Upgrade to release 1.1: - Drop support for Python 3.3. - Drop support for Python 3.4. - Deprecate the html5lib sanitizer (html5lib.serialize(sanitize=True) and html5lib.filters.sanitizer). We recommend users migrate to Bleach <https://github.com/mozilla/bleach>. - Try to import from collections.abc to remove DeprecationWarning and ensure html5lib keeps working in future Python versions. - Drop optional datrie dependency. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-html5lib_1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-html5lib_1.1.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb b/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb
new file mode 100644
index 0000000000..59f3cc9455
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-html5lib_1.1.bb
@@ -0,0 +1,17 @@
+SUMMARY = "HTML parser based on the WHATWG HTML specifcation"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c"
+
+SRC_URI[md5sum] = "6748742e2ec4cb99287a6bc82bcfe2b0"
+SRC_URI[sha256sum] = "b2e5b40261e20f354d198eae92afc10d750afb487ed5e50f9c4eaf07c184146f"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-lxml \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-webencodings \
+ ${PYTHON_PN}-xml \
+"
+
+BBCLASSEXTEND = "native nativesdk"