aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-10-23 16:46:47 +0800
committerKhem Raj <raj.khem@gmail.com>2023-10-23 08:05:02 -0700
commit867fb4c7d0bdf0b895b9cbe0d9a100f7b8e3a9f9 (patch)
tree5d23bb788fa828df6711636c38a6e0d44bcb9500 /meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb
parent378ba35bbcf900c04b6195440826e9b12c018f38 (diff)
downloadmeta-openembedded-867fb4c7d0bdf0b895b9cbe0d9a100f7b8e3a9f9.tar.gz
python3-h5py: upgrade 3.9.0 -> 3.10.0
Changelog: https://docs.h5py.org/en/stable/whatsnew/3.10.html#bug-fixes Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb b/meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb
new file mode 100644
index 0000000000..400233e64a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-h5py_3.10.0.bb
@@ -0,0 +1,39 @@
+SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python."
+HOMEPAGE = "https://www.h5py.org/"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c"
+
+SRC_URI[sha256sum] = "d93adc48ceeb33347eb24a634fb787efc7ae4644e6ea4ba733d099605045c049"
+
+SRC_URI += "file://0001-setup_build.py-avoid-absolute-path.patch"
+
+inherit pkgconfig pypi setuptools3
+
+BBCLASSEXTEND = "native"
+
+DEPENDS = "python3-pkgconfig-native \
+ python3-cython-native \
+ python3-numpy-native \
+ python3-six-native \
+ hdf5-native \
+ python3 \
+ hdf5 \
+ "
+
+PACKAGESPLITFUNCS =+ "fix_cythonized_sources"
+
+fix_cythonized_sources() {
+ for f in `grep -l -r -e '\/* Generated by Cython.*/$' ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}`; do
+ if [ -e $f ]; then
+ sed -i -e 's#${RECIPE_SYSROOT_NATIVE}##g' $f
+ fi
+ done
+}
+
+RDEPENDS:${PN} = "python3-numpy \
+ python3-six \
+ python3-json \
+ "
+
+export HDF5_VERSION="1.14.0"