aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb
diff options
context:
space:
mode:
authorZang Ruochen <zangrc.fnst@cn.fujitsu.com>2020-06-15 22:36:56 +0800
committerKhem Raj <raj.khem@gmail.com>2020-06-17 08:55:53 -0700
commit3a05a4e325d72cbf36d28675537a955f34af9d2a (patch)
tree29a31e903874188a5c015c48b1bb79ed5e775363 /meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb
parent4d5162a0301f76a2ea1a8483254e17621f1ed2a0 (diff)
downloadmeta-openembedded-3a05a4e325d72cbf36d28675537a955f34af9d2a.tar.gz
python3-geojson: Enable ptest
Signed-off-by: Zang Ruochen <zangrc.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb b/meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb
index 7c3c23b221..c3fd37c8b7 100644
--- a/meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb
@@ -6,7 +6,20 @@ LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=f48972abe5cddee79e301574742ed745"
SRC_URI[md5sum] = "14753ed28678828b1de73f68b04e2324"
SRC_URI[sha256sum] = "6e4bb7ace4226a45d9c8c8b1348b3fc43540658359f93c3f7e03efa9f15f658a"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
RDEPENDS_${PN} += "python3-simplejson python3-math"