aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2020-03-24 15:48:36 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-24 19:58:50 -0700
commit3846551c912e0fb1afa4ede1b4bdec348299339c (patch)
tree95bf2b3baa583dce4dd379a5690de0e5ee013384 /meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb
parent81bbbe8c6938f769496b290e556f8e749126307b (diff)
downloadmeta-openembedded-3846551c912e0fb1afa4ede1b4bdec348299339c.tar.gz
python3-geojson: add recipe for 2.5.0
Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb b/meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb
new file mode 100644
index 0000000000..7c3c23b221
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-geojson_2.5.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Python bindings and utilities for GeoJSON"
+HOMEPAGE = "https://pypi.org/project/geojson/"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=f48972abe5cddee79e301574742ed745"
+
+SRC_URI[md5sum] = "14753ed28678828b1de73f68b04e2324"
+SRC_URI[sha256sum] = "6e4bb7ace4226a45d9c8c8b1348b3fc43540658359f93c3f7e03efa9f15f658a"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-simplejson python3-math"
+
+BBCLASSEXTEND = "native nativesdk"