aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-12-07 15:23:54 -0800
committerKhem Raj <raj.khem@gmail.com>2023-12-21 08:00:41 -0800
commite592a8ce9a3e4cc7ad9e2e0da67e5afa9a38186a (patch)
treece8e49e7054562dd96b8b3437588b0bb23eabe6b /meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
parent537a9e24c6d5e2a5a0b177bb572b8a3ce95a485e (diff)
downloadmeta-openembedded-e592a8ce9a3e4cc7ad9e2e0da67e5afa9a38186a.tar.gz
python3-dirty-equals: add v0.7.1
Dependency for python3-pydantic-core ptests. """ dirty-equals is a python library that (mis)uses the __eq__ method to make python code (generally unit tests) more declarative and therefore easier to read and write. dirty-equals can be used in whatever context you like, but it comes into its own when writing unit tests for applications where you're commonly checking the response to API calls and the contents of a database. Signed-off-by: Tim Orling <ticotimo@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb b/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
new file mode 100644
index 0000000000..ea9303b17e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dirty-equals_0.7.1.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Doing dirty (but extremely useful) things with equals."
+DESCRIPTION = "dirty-equals is a python library that (mis)uses the \
+__eq__ method to make python code (generally unit tests) more \
+declarative and therefore easier to read and write.\
+\
+dirty-equals can be used in whatever context you like, but it comes \
+into its own when writing unit tests for applications where you're \
+commonly checking the response to API calls and the contents of a database."
+HOMEPAGE = "https://github.com/samuelcolvin/dirty-equals"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ab599c188b4a314d2856b3a55030c75c"
+
+SRC_URI[sha256sum] = "a580513f3285e93656a770a04e428f8bfc513848877bf278282dbfbb907fdbb4"
+
+S = "${WORKDIR}/dirty_equals-${PV}"
+
+inherit pypi python_hatchling
+
+PYPI_PACKAGE = "dirty_equals"
+
+RDEPENDS:${PN} += "python3-pytz"