aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography_3.3.1.bb
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2021-04-21 10:33:23 +0800
committerKhem Raj <raj.khem@gmail.com>2021-04-21 08:26:07 -0700
commit34f9b39e4be9041186894619e81e8c52dd6c3aef (patch)
tree1691957c5d703f3c7da9686375c6b3428f950434 /meta-python/recipes-devtools/python/python3-cryptography_3.3.1.bb
parenta2ebdf3fe3ecae5b2c8a286d08c55d92d388ef67 (diff)
downloadmeta-openembedded-34f9b39e4be9041186894619e81e8c52dd6c3aef.tar.gz
python3-cryptography: Upgrade to 3.3.2
Fix a security issue CVE-2020-36242 where certain sequences of ``update()`` calls when symmetrically encrypting very large payloads (>2GB) could result in an integer overflow, leading to buffer overflows. Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography_3.3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_3.3.1.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_3.3.1.bb b/meta-python/recipes-devtools/python/python3-cryptography_3.3.1.bb
deleted file mode 100644
index 79a7ac1bf9..0000000000
--- a/meta-python/recipes-devtools/python/python3-cryptography_3.3.1.bb
+++ /dev/null
@@ -1,65 +0,0 @@
-SUMMARY = "Provides cryptographic recipes and primitives to python developers"
-HOMEPAGE = "https://cryptography.io/"
-SECTION = "devel/python"
-LICENSE = "Apache-2.0 | BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=bf405a8056a6647e7d077b0e7bc36aba"
-
-LDSHARED += "-pthread"
-
-SRC_URI[sha256sum] = "7e177e4bea2de937a584b13645cab32f25e3d96fc0bc4a4cf99c27dc77682be6"
-
-SRC_URI += " \
- file://run-ptest \
- file://h-test.patch \
-"
-
-inherit pypi setuptools3
-
-DEPENDS += " \
- ${PYTHON_PN}-cffi \
- ${PYTHON_PN}-cffi-native \
- ${PYTHON_PN}-asn1crypto \
- ${PYTHON_PN}-six \
-"
-
-RDEPENDS_${PN} += " \
- ${PYTHON_PN}-cffi \
- ${PYTHON_PN}-idna \
- ${PYTHON_PN}-asn1crypto \
- ${PYTHON_PN}-setuptools \
- ${PYTHON_PN}-six \
-"
-
-RDEPENDS_${PN}_class-target += " \
- ${PYTHON_PN}-cffi \
- ${PYTHON_PN}-idna \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-asn1crypto \
- ${PYTHON_PN}-setuptools \
- ${PYTHON_PN}-six \
- ${PYTHON_PN}-threading \
-"
-
-RDEPENDS_${PN}-ptest += " \
- ${PN} \
- ${PYTHON_PN}-cryptography-vectors \
- ${PYTHON_PN}-iso8601 \
- ${PYTHON_PN}-pretend \
- ${PYTHON_PN}-pytest \
- ${PYTHON_PN}-pytz \
-"
-
-inherit ptest
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/tests
- cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
- install -d ${D}${PTEST_PATH}/tests/hazmat
- cp -rf ${S}/tests/hazmat/* ${D}${PTEST_PATH}/tests/hazmat/
-}
-
-FILES_${PN}-dbg += " \
- ${libdir}/${PYTHON_PN}2.7/site-packages/${SRCNAME}/hazmat/bindings/.debug \
-"
-
-BBCLASSEXTEND = "native nativesdk"