aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-15 12:35:54 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-16 12:52:19 -0800
commita14a6159f7a7d3d8301bfa320e4c0fd9b1587e34 (patch)
tree6915dac6e5f0ed1c089beba40395e6e49c8bd453 /meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb
parentfb58592c7042d7e2164d0c1da35793d17f85c008 (diff)
downloadmeta-openembedded-a14a6159f7a7d3d8301bfa320e4c0fd9b1587e34.tar.gz
python3-configargparse: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb b/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb
index 698eccf666..0797898a9c 100644
--- a/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb
+++ b/meta-python/recipes-devtools/python/python3-configargparse_0.15.1.bb
@@ -1,3 +1,22 @@
-inherit setuptools3
-require python-configargparse.inc
+SUMMARY = "A drop-in replacement for argparse that allows options to also be set via config files and/or environment variables."
+HOMEPAGE = "https://github.com/bw2/ConfigArgParse"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=da746463714cc35999ed9a42339f2943"
+
+SRC_URI[md5sum] = "aba15b7973b7a70bea86fd69289f8fe3"
+SRC_URI[sha256sum] = "baaf0fd2c1c108d007f402dab5481ac5f12d77d034825bf5a27f8224757bd0ac"
+
+PYPI_PACKAGE = "ConfigArgParse"
+
+inherit pypi setuptools3
+
+PACKAGECONFIG ?= "yaml"
+PACKAGECONFIG[yaml] = ",,,${PYTHON_PN}-pyyaml"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"