aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-02-14 18:08:19 -0500
committerKhem Raj <raj.khem@gmail.com>2020-02-15 08:05:07 -0800
commitbbe7eb6c339611dc6d2686461476637e203fddc4 (patch)
tree3fddef324c1b2707d7374b5fa5ad7c5da7149131 /meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb
parent90ca842c7a4f08e66cc3d1eb11fc0b3a1129526a (diff)
downloadmeta-openembedded-bbe7eb6c339611dc6d2686461476637e203fddc4.tar.gz
python3-cffi: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb19
1 files changed, 18 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb b/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb
index e888084347..53c8ee2650 100644
--- a/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb
+++ b/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb
@@ -1,2 +1,19 @@
+SUMMARY = "Foreign Function Interface for Python calling C code"
+HOMEPAGE = "http://cffi.readthedocs.org/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf"
+DEPENDS += "libffi ${PYTHON_PN}-pycparser"
+
+SRC_URI[md5sum] = "74845f8d2b7b583dd9a3574f402edf39"
+SRC_URI[sha256sum] = "2d384f4a127a15ba701207f7639d94106693b6cd64173d6c8988e2c25f3ac2b6"
+
inherit pypi setuptools3
-require python-cffi.inc
+
+RDEPENDS_${PN}_class-target = " \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-pycparser \
+ ${PYTHON_PN}-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"