aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-booleanpy_3.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-19 12:46:36 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-22 08:38:19 -0700
commit9c68f1216bb009f400f327d0c2579a1e83f5fc99 (patch)
tree6e5a6ca30eb29bfe7d08917e3956cd72b7589ef6 /meta-python/recipes-devtools/python/python3-booleanpy_3.8.bb
parent50cd88ed6bb34f95589176e01269467db86089d2 (diff)
downloadmeta-openembedded-9c68f1216bb009f400f327d0c2579a1e83f5fc99.tar.gz
python3-booleanpy: Upgrade 3.7 to 3.8
Upgrade to release 3.8: - Add support for evaluation of boolean expression. - Fix parsing of tokens that have a number as the first character. - Restore proper Python 2 compatibility. - Add pointers to Linux distro packages. Change LICENSE.txt md5 checksum because the year has been updated. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-booleanpy_3.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-booleanpy_3.8.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-booleanpy_3.8.bb b/meta-python/recipes-devtools/python/python3-booleanpy_3.8.bb
new file mode 100644
index 0000000000..a1ce7eafc9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-booleanpy_3.8.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Define boolean algebras, create and parse boolean expressions and create custom boolean DSL"
+HOMEPAGE = "https://github.com/bastikr/boolean.py"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9b58494d4f385978ca5a7ef4f6abca53"
+
+SRC_URI[md5sum] = "83ccc145ba74a585637124c8bc648333"
+SRC_URI[sha256sum] = "cc24e20f985d60cd4a3a5a1c0956dd12611159d32a75081dabd0c9ab981acaa4"
+
+PYPI_PACKAGE = "boolean.py"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"