aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
diff options
context:
space:
mode:
authorniko.mauno@vaisala.com <niko.mauno@vaisala.com>2020-05-09 17:06:01 +0000
committerKhem Raj <raj.khem@gmail.com>2020-05-09 10:41:48 -0700
commit129efc7fa0c04ee812a972fc5b63990fe74288ea (patch)
tree42f7aaf981feb3fbf26693043e2630189ce84215 /meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
parentc966d3f063a9f159fd8db532b8034435e1cf3964 (diff)
downloadmeta-openembedded-129efc7fa0c04ee812a972fc5b63990fe74288ea.tar.gz
python3-attrs: Add nativesdk to BBCLASSEXTEND
By doing so we mitigate failure when trying to bitbake recipe which rdepends on nativesdk-python3-attrs, such as following error when bitbaking nativesdk-python3-jsonschema: ERROR: Nothing RPROVIDES 'nativesdk-python3-attrs' (but virtual:nativesdk:.../meta-openembedded/meta-python/recipes-devtools/python/python3-jsonschema_3.2.0.bb RDEPENDS on or otherwise requires it) Signed-off-by: Niko Mauno <niko.mauno@vaisala.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb b/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
index b3739fda8c..7ff8049e52 100644
--- a/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
+++ b/meta-python/recipes-devtools/python/python3-attrs_19.3.0.bb
@@ -12,5 +12,9 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-crypt \
${PYTHON_PN}-ctypes \
"
+RDEPENDS_${PN}_class-nativesdk += " \
+ ${PYTHON_PN}-crypt \
+ ${PYTHON_PN}-ctypes \
+"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"