aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb
diff options
context:
space:
mode:
authorRyan Rowe <rrowe@xevo.com>2020-06-17 12:15:51 -0700
committerKhem Raj <raj.khem@gmail.com>2020-06-18 17:56:07 -0700
commit7a742c76700521f190101f7dc2910e4154fb965c (patch)
tree0c2f017ee6640f92be606ee3e4876b6d82b79e77 /meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb
parentb6c791ac78d0fe04adfb3cf5a2f62a822c1f2cde (diff)
downloadmeta-openembedded-7a742c76700521f190101f7dc2910e4154fb965c.tar.gz
add python3-argexec
Signed-off-by: Ryan Rowe <rrowe@xevo.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb b/meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb
new file mode 100644
index 0000000000..179e071277
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-argexec_1.0.2.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Expose your Python functions to the command line with one easy step!"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ea70b07c354e36056bd35e17c9c3face"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "9fac09884c54db79e57ab80f0c423794"
+SRC_URI[sha256sum] = "e271286b280f930aeaae7496454573f8029c3f48ef1dc47c780155dd4a7b9e7f"
+
+DEPENDS += "python3-setuptools-scm-native"
+RDEPENDS_${PN} += "\
+ python3-typing \
+ python3-dynamic-dispatch \
+ python3-typeguard \
+"
+
+BBCLASSEXTEND = "native nativesdk"