aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-05-24 09:52:35 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-24 07:23:54 -0700
commit07fad37c9818a9f365c1f82f6f1907cafdb1d1f6 (patch)
tree1870794108a077e2cf18f70ad2fc88680a1c7b0b /meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
parent26397c2ea3fe904cc99cd767c9e2b1c5b3840321 (diff)
downloadmeta-openembedded-07fad37c9818a9f365c1f82f6f1907cafdb1d1f6.tar.gz
meta-python: remove unused patches from python2 recipes
* python2 recipes were removed in: https://git.openembedded.org/meta-openembedded/commit/?id=05d0c5eee319055816bbea8b9dd972f723f68019 but some of the unused patch files were left behind * meta-python/recipes-devtools/python/python-pyrex/pyrex-fix-optimized-mode.patch: https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch meta-python/recipes-devtools/python/python-imaging/fix-freetype-includes.patch meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a * meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a * meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-numeric_24.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch55
1 files changed, 0 insertions, 55 deletions
diff --git a/meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch b/meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
deleted file mode 100644
index 2575306bec..0000000000
--- a/meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From 07d4f095a9e22ae676a8d68073101131e65012dc Mon Sep 17 00:00:00 2001
-From: Koen Kooi <koen@dominion.thruhere.net>
-Date: Tue, 15 Nov 2011 13:16:54 +0100
-Subject: [PATCH] python imaging setup.py: force paths for zlib, freetype and jpeg and don't add host paths
-
-Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-
-Upstream-Status: Inappropriate [embedded specific]
----
- setup.py | 14 +++-----------
- 1 files changed, 3 insertions(+), 11 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 5d4d53a..b1a22ec 100644
---- a/setup.py
-+++ b/setup.py
-@@ -34,10 +34,10 @@ def libinclude(root):
- # TIFF_ROOT = libinclude("/opt/tiff")
-
- TCL_ROOT = None
--JPEG_ROOT = None
--ZLIB_ROOT = None
-+JPEG_ROOT = os.environ['STAGING_LIBDIR']
-+ZLIB_ROOT = os.environ['STAGING_LIBDIR']
- TIFF_ROOT = None
--FREETYPE_ROOT = None
-+FREETYPE_ROOT = os.environ['STAGING_LIBDIR'], os.environ['STAGING_INCDIR']
- LCMS_ROOT = None
-
- # FIXME: add mechanism to explicitly *disable* the use of a library
-@@ -147,7 +147,6 @@ class pil_build_ext(build_ext):
- add_directory(library_dirs, "/opt/local/lib")
- add_directory(include_dirs, "/opt/local/include")
-
-- add_directory(library_dirs, "/usr/local/lib")
- # FIXME: check /opt/stuff directories here?
-
- prefix = sysconfig.get_config_var("prefix")
-@@ -207,13 +206,6 @@ class pil_build_ext(build_ext):
- if os.path.isfile(os.path.join(tcl_dir, "tk.h")):
- add_directory(include_dirs, tcl_dir)
-
-- # standard locations
-- add_directory(library_dirs, "/usr/local/lib")
-- add_directory(include_dirs, "/usr/local/include")
--
-- add_directory(library_dirs, "/usr/lib")
-- add_directory(include_dirs, "/usr/include")
--
- #
- # insert new dirs *before* default libs, to avoid conflicts
- # between Python PYD stub libs and real libraries
---
-1.7.2.5
-