aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-03-29 15:58:54 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-29 17:32:21 -0700
commit76db1c71ef8fc6e6f521f921b3361b37d96e6e3c (patch)
treea0111e90a1431b3f8da293c85089366dd4303a42 /meta-oe
parentab240b90dd73829af33db7acd0e5d6c2f2453a52 (diff)
downloadmeta-openembedded-76db1c71ef8fc6e6f521f921b3361b37d96e6e3c.tar.gz
debsums: Depend on po4a-native
- Move to perl dynamic-layer since po4a comes from meta-perl - Add meta-perl dynamic layer Fixes cd man && po4a --no-translations po4a.cfg /bin/sh: po4a: command not found make: *** [Makefile:11: clean] Error 127 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/conf/layer.conf4
-rw-r--r--meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb (renamed from meta-oe/recipes-support/debsums/debsums_2.2.2.bb)2
2 files changed, 5 insertions, 1 deletions
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf
index 434537fd3a..adcec83029 100644
--- a/meta-oe/conf/layer.conf
+++ b/meta-oe/conf/layer.conf
@@ -25,7 +25,9 @@ BBFILE_PRIORITY_openembedded-layer = "6"
# only activates content when identified layers are present,
# to ensure yocto compatibility check pass
-BBFILES_DYNAMIC += "meta-python:${LAYERDIR}/dynamic-layers/meta-python/recipes-*/*/*.bb \
+BBFILES_DYNAMIC += " \
+meta-python:${LAYERDIR}/dynamic-layers/meta-python/recipes-*/*/*.bb \
+perl-layer:${LAYERDIR}/dynamic-layers/perl-layer/recipes-*/*/*.bb \
"
# This should only be incremented on significant changes that will
diff --git a/meta-oe/recipes-support/debsums/debsums_2.2.2.bb b/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
index 13f20eb944..07ab5e62b1 100644
--- a/meta-oe/recipes-support/debsums/debsums_2.2.2.bb
+++ b/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
@@ -20,6 +20,8 @@ UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/${BPN}/"
inherit perlnative gettext
+DEPENDS += "po4a-native"
+
do_install() {
install -d ${D}/${sysconfdir}/cron.daily ${D}/${sysconfdir}/cron.weekly
install -d ${D}/${sysconfdir}/cron.monthly ${D}${sbindir} ${D}${bindir}