aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2019-02-24 09:56:50 +0000
committerKhem Raj <raj.khem@gmail.com>2019-02-24 08:07:53 -0800
commit676a4c806c7abcbc3a48a70e8ac0abdac19362e1 (patch)
tree915b83226d5296b3ddd1fc87fb4a6a240208b208 /meta-oe
parent5f787686697fe36e3e7b64d3552f4cf543d33149 (diff)
downloadmeta-openembedded-676a4c806c7abcbc3a48a70e8ac0abdac19362e1.tar.gz
vim: use empty PACKAGECONFIG for vim-native
* otherwise it depends on gtk+-native and we don't need gtkgui enabled in native builds as vim-native was introduced only for xxd-native in: commit 1dff2351aa6cdafa5a501e8956cb853ab17ed9ae Author: Martin Jansa <Martin.Jansa@gmail.com> Date: Fri Mar 10 11:55:44 2017 +0100 vim: add native BBCLASSEXTEND * some recipes might use xxd * with stricter host binaries available in PATH: http://lists.openembedded.org/pipermail/openembedded-core/2017-March/133886.html we cannot use xxd from host and it's not so common to add it into HOSTTOOL_NONFATAL * there is also smaller solution for xxd -i (which is what I need): https://github.com/gregkh/xxdi but after creating xxdi-native recipe for this I've discovered that perl on my host as well as perlnative doesn't provide File::Slurp used by this, so adding BBCLASSEXTEND here is easier solution Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/vim/vim_8.1.0347.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/vim/vim_8.1.0347.bb b/meta-oe/recipes-support/vim/vim_8.1.0347.bb
index 0705831584..2a3d14a2ce 100644
--- a/meta-oe/recipes-support/vim/vim_8.1.0347.bb
+++ b/meta-oe/recipes-support/vim/vim_8.1.0347.bb
@@ -40,6 +40,7 @@ PACKAGECONFIG += " \
${@bb.utils.filter('DISTRO_FEATURES', 'acl selinux', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11 gtkgui', '', d)} \
"
+PACKAGECONFIG_class-native = ""
PACKAGECONFIG[gtkgui] = "--enable-gui=gtk2,--enable-gui=no,gtk+,"
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"